Visual Editor not Working in Wordpress



If you have update your wordpress software and installed new version 3.5, 3.4, 3.1 or any other, you will see when you post your content by clicking Add New in the posts menu. If you are on text or html editor, it will not shifted to visual editor. If you are on visual editor, it will not be shifted to text or html editor.

For more than one hour, I have tried. By clicking on the visual editor but it is not giving me any response. It is not working. It is not opening. So, I started to search

"Visual Editor not Working in Wordpress" on Google and Google has given me lots of information. I opened pages one by one for learning the solid way to solve this problem.  Finally, I have succeeded to solve this problem. Solution is very very simple.

1st Step : Delete All cache




Just press Ctrl+h, you will see history of browser. Check the box empty all cache. click on clear all browsing data. Remember you should set " obliterate the following items" from beginning of time.

2nd Step : Install "Use Google Libraries"


Just click new plugin in your wordpress account and search use google libraries  Install it and you will see that your visual editor will be working.  What will happen after installing use google libraries.
This plugin allows your WordPress site to use the content distribution network side of Google’s AJAX Library API, rather than serving these files from your WordPress install directly.

As per the plugin site( http://jasonpenney.net/wordpress-plugins/use-google-libraries/ ), following are its benefits.

  • increases the chance that a user already has these files cached

  • takes load off your server

  • uses compressed versions of the libraries (where available)

  • Google’s servers are set up to negotiate HTTP compression with the requesting browser

Vinod Kumar

Educator

Prof. Vinod Kumar is an Indian Educator, Motivational Speaker, Naturopathic Practitioner and Entrepreneur . He is the founder of Svtuition... read more »

2 comments:

  1. Here is the fix for this problem:

    1- download the wp-config.php file from your server

    2- add this to the wp-config.php file:
    define('SCRIPT_DEBUG', true);

    3- re-upload the wp-config.php file and over write the current wp-config.php file.

    4- log out of your WordPress Admin

    5- close and then re-open your browser

    6- log into your WordPress admin and the visual tab will now work

    ReplyDelete
  2. Worked perfectly - thank you for documenting this!!

    ReplyDelete